problèmes d'autorisations écrit avec les répertoires suivants / fichiers répertoire de Elementor

voix
0

Chaque fois que je veux mettre à jour une page spécifique sur mon site wordpress la page par se fige et ne me laisse pas utiliser le générateur. Sur Wordpress Dashboard Je vois ce message: Rédaction des problèmes d'autorisations avec les répertoires suivants / fichiers répertoire de Elementor.

Quand je vérifie les journaux d'erreur je trouve ce qui suit:

`[error] 14605#14605: *52603 FastCGI sent in stderr: PHP message: PHP Warning:
  file_put_contents(/var/www/corvettes2.performancecorvettes.com/public/wp-content/uploads/elementor/css/post-701.css): 
failed to open stream: 
Permission denied in /var/www/corvettes2.performancecorvettes.com/public/
wp-content/plugins/elementor/core/files/base.php` 

Ce que j'ai essayé jusqu'à présent:

  1. Je me assure que je l' ai mis les autorisations appropriées sur les dossiers et les fichiers (755 dossiers et sous - dossiers, 644 fichiers)
  2. Je modifie les max_input_vars à 1000 sur le htaccess fichier
  3. Je vérifier le nginx conf fichier à assurer que rien est étrange (encore je ne trouve rien de mal):

;

 user  nginx;
 worker_processes  auto;
 worker_rlimit_nofile 20000;
 error_log  /var/log/nginx/error.log warn;
 pid        /var/run/nginx.pid;


  events {
  worker_connections  4096;
  multi_accept on;
  use epoll;
}


 http {
    include       /etc/nginx/mime.types;
    default_type  application/octet-stream;

log_format  main  '$remote_addr - $remote_user [$time_local] $request '
                  '$status $body_bytes_sent $http_referer '
                  '$http_user_agent $http_x_forwarded_for';

access_log  /var/log/nginx/access.log  main;

sendfile on;
tcp_nopush on;
tcp_nodelay on;

keepalive_requests 100000;
keepalive_timeout  5;
send_timeout 10;

gzip  on;
gzip_http_version 1.0;
gzip_comp_level 2;
gzip_proxied any;
gzip_vary off;
gzip_types text/plain text/css text/xml application/xml application/rss+xml application/atom+xml application/x-font-ttf application/font-woff application/vnd.ms-fontobject application/javascript application/json application/x-javascript application/x-httpd-php application/x-httpd-fastphp application/x-httpd-eruby image/svg+xml text/javascript text/mathml;
gzip_min_length  1000;
gzip_disable     MSIE [1-6]\.;

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;
client_max_body_size 20M;
}
Créé 14/02/2020 à 00:06
source utilisateur
Dans d'autres langues...                            


1 réponses

voix
0

Vérifiez la propriété du répertoire de téléchargement et il est des fichiers. Très probablement, ils sont la propriété de root ou un autre utilisateur. Dans ce cas, utilisez la commande chmod changer à l'utilisateur nginx.

Créé 14/02/2020 à 02:31
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more