Je ne parviens pas à mettre en question avant par défaut pour les brouillons ou les messages lors de l'utilisation Jekyll-Compose

voix
0

J'ai installé le joyau jekyll-Compose pour simplifier la création de pages, messages , etc. Dans la documentation . Je l' ai travail ( par exemple en utilisant les commandes CLI je suis en mesure de générer, brouillons, messages et pages).

Cependant, quand je produis un poste par exemple, je veux qu'il y ait certaines variables en la matière avant. Il existe des fonctionnalités mentionnées dans le fichier Lisez-moi de Jekyll Compose qui indique que vous pouvez définir les valeurs par défaut de matière avant pour les postes et les courants d'air.

Je l'ai suivi les instructions en ajoutant les lignes requises dans le config.yaml de mon site, mais des postes et des courants d'air à l'aide que je générons jekyll-Compose ne génèrent pas les variables que je veux.

Jekyll-Compose stipule que si vous voulez par défaut des variables de matière avant que vous avez besoin d'ajouter quelque chose comme ceci à votre _config.yaml:

jekyll_compose:
  default_front_matter:
    drafts:
      description:
      image:
      category:
      tags:
    posts:
      description:
      image:
      category:
      tags:
      published: false
      sitemap: false

Je l'ai essayé à la fois leur configuration par défaut ci-dessus et ci-dessous mon

jekyll_compose:
  default_front_matter:
    drafts:
      main_img_url:
      author_name:
      categories:
      description:
    posts:
      main_img_url:
      author_name:
      categories:
      description:

Mais ni travail quand je produis un nouveau poste ou projet. Il n'y a aucun message d'erreur qui rend difficile la mise au point.

A l'origine ma version Jekyll était à 3.7.0, je pensais que ce serait peut-être un problème d'une version Jekyll étant trop vieux. Toutefois, ce problème a persisté quand je mis à jour Jekyll à 3.8.6.

Il ne fonctionne pas lorsque je mets les valeurs par défaut pour mes variables personnalisées, à savoir:

jekyll_compose:
  default_front_matter:
    drafts:
        main_img_url: https://images-we-got-pop.imgix.net/website/blog/pop-logo-small.png
        author_name: Me
        categories: general
        description: Description
    posts:
        main_img_url: https://images-we-got-pop.imgix.net/website/blog/pop-logo-small.png
        author_name: Me
        categories: general
        description: Description

Mon fichier _config ressemble à ceci:

title: Title
email: your-email@domain.com
description: > # this means to ignore newlines until baseurl:
  Write an awesome description for your new site here. You can edit this
  line in _config.yml. It will appear in your document head meta (for
  Google search results) and in your feed.xml site description.
baseurl:  # the subpath of your site, e.g. /blog
url:  # the base hostname & protocol for your site, e.g. http://example.com
twitter_username: name
github_username:  name

# Build settings
markdown: kramdown
theme: minima
plugins:
  - jekyll-feed
  - jekyll-paginate-v2
exclude:
  - Gemfile
  - Gemfile.lock
  - Makefile
  - README.md

permalink: /pages/:year/:month/:day/:title/

jekyll_compose:
  default_front_matter:
    drafts:
      main_img_url:
      author_name:
      categories:
      description:
    posts:
      main_img_url:
      author_name:
      categories:
      description:

future: true

pagination:
  enabled: true
  sort_reverse: true
  trail:
    before: 1
    after: 1

et mon Gemfile ressemble à ceci:

source https://rubygems.org
ruby RUBY_VERSION

gem jekyll, 3.8.6

# This is the default theme for new Jekyll sites. You may change this to anything you like.
gem minima, ~> 2.0

# If you want to use GitHub Pages, remove the gem jekyll above and
# uncomment the line below. To upgrade, run `bundle update github-pages`.
# gem github-pages, group: :jekyll_plugins

# If you have any plugins, put them here!
group :jekyll_plugins do
   gem jekyll-feed, ~> 0.6
   gem jekyll-paginate-v2, ~> 1.9
   gem 'jekyll-compose', ~> 0.11
end

J'attends ma question avant personnalisé pour apparaître dans mes nouveaux messages générés:

---
title: this-is-a-new-post
date: 2019-10-09 10:45 +0100
main_img_url:
author_name:
categories:
description:
---

Mais je ne reçois que les standards qui sont créées avec le poste / projet, par exemple:

---
title: this-is-a-new-post
date: 2019-10-09 10:45 +0100
---

Des idées??

Créé 09/10/2019 à 13:00
source utilisateur
Dans d'autres langues...                            


1 réponses

voix
0

Ok j'ai réussi à réparer moi-même après avoir vu la syntaxe pour les variables personnalisées était différent sur GH par rapport à ce que je trouve en creusant dans les méthodes de création post-Compose sur jekyll rubydoc.info.

Fondamentalement, il y avait PR qui a changé la syntaxe fusionné pour maîtriser, mais pas encore sorti, donc pourquoi j'avais du mal à le faire fonctionner

La syntaxe actuelle à partir de la dernière version:

jekyll_compose:
  draft_default_front_matter:
    description:
    image:
    category:
    tags:
  post_default_front_matter:
    description:
    image:
    category:
    tags:
    published: false
    sitemap: false

la nouvelle syntaxe qui existe dans le fichier Readme et maître, mais n'a pas encore été publié:

jekyll_compose: jekyll_compose:
  default_front_matter:
    drafts:
      description:
      image:
      category:
      tags:
    posts:
      description:
      image:
      category:
      tags:
      published: false
      sitemap: false
``` ```
Créé 09/10/2019 à 14:10
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more