8 angulaires composants Web

voix
-1

Ceci est mon premier temps à travailler sur des composants Web angulaires. J'ai essayé beaucoup tutoriel en ligne et même des tutoriels vidéo, je vois que les exemples présentés dans le tutoriel sont des 5/6/7 angulaires versions, mais ne peuvent pas trouver par exemple ou tutoriel pour 8 angulaire.

Comme sur npm run builddans angulaire 5/6/7 versions , il générerait ces fichiers:

./dist/my-app/runtime.js,
./dist/my-app/polyfills.js,
./dist/my-app/scripts.js,
./dist/my-app/main.js

mais angulaire 8 génère ces fichiers:

./dist/my-app/runtime-es2015.js,
./dist/my-app/runtime-es2015.js,
./dist/my-app/polyfills-es2015.js,
./dist/my-app/polyfills-es5.js,
./dist/my-app/scripts.js,
./dist/my-app/main-es5.js
./dist/my-app/main-es2015.js

J'ai essayé ces tutoriels Web Components avec angulaire

Composants Web à l'aide angulaire - Etes-vous sûr?

Je suis coincé sur cette partie

créer un script pour éjecter notre composant Web en un seul fichier

car les fichiers ne correspondent pas

Créé 09/10/2019 à 12:58
source utilisateur
Dans d'autres langues...                            


1 réponses

voix
0

Elle est due à une charge différentielle. Une nouvelle fonctionnalité introduite dans angulaire 8 pour charger l'application dans tous les navigateurs. Dans le fichier angulaire 8 browserList doivent être dans le dossier racine du projet. les entrées suivantes ont été nécessaires sur le projet pour désactiver le chargement différentiel et qui aide à correspondre à des fichiers

> 0.5%
last 2 versions
Firefox ESR
not dead
not IE 9-11
not samsung 4
not android 4.4.3-4.4.4
not last 2 ie_mob versions
not last 2 op_mini versions
not last 2 op_mob versions
not last 2 baidu versions
not last 2 kaios versions
not last 2 and_uc versions
not last 2 and_qq versions
not last 2 edge versions
not chrome 49
Créé 09/10/2019 à 13:06
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more