Comment donner accès NT AUTHORITY \ IUSR au contenu du dossier partagé?

voix
6

Je trouve quelque chose lié, mais pas la même chose.

L'erreur « Échec de la connexion pour l'utilisateur 'NT AUTHORITY \ IUSR » dans ASP.NET et SQL Server 2008

Mon problème est que les fichiers sont partagés sur le réseau, et je voudrais déboguer de IIS local, je trouve que tous les fichiers statiques semble être vu refuser l'accès (401,3)

Je l'ai utilisé le système de trace, et constater que l'IIS accède à la source à l'aide « NT AUTHORITY \ IUSR »

Url http://localhost:8451/umbraco_client/panel/images/panel_boxhead_h2_bg.gif 
App Pool Debug451 
Authentication anonymous 
User from token NT AUTHORITY\IUSR 
Activity ID 

J'ai mis le dossier partagé pour être accessible à tous, et changé l'identité du pool d'applications à l'administrateur de domaine.

J'ai aussi essayé d'utiliser « Network Service » comme identité et attribuer le domaine \ MachineName $ accès complet au dossier partagé ...

Il me semble que iis toujours en utilisant « NT AUTHORITY \ IUSR » pour accéder resouce statique? Si oui, comment puis-je donner accès à un dossier partagé à un compte local? Ou comment une autre identité puis-je forcer IIS à utiliser?


mise à jour: comme il y a une nouvelle réponse à cette vieille question que j'ai abandonné à ce moment-là. Je accentually rencontrer ce problème similaire encore récemment sur un serveur exécutant Windows 2008 R2, que je résolus, et je voudrais donner une mise à jour.

Je résoudre le problème cette fois -ci par ajouter une autorisation de lecture $ ComputerName / utilisateurs . Cela ne semble un problème avec l' environnement du serveur, et ne sais pas si lié à une politique ou même type groupe. Espérons que cela pourrait aider quelqu'un à l' avenir.

Créé 17/08/2010 à 17:00
source utilisateur
Dans d'autres langues...                            


4 réponses

voix
1

Une fois que vous avez configuré l'utilisateur du pool d'applications pour avoir l'autorisation d'accès au dossier partagé (créer un nouvel utilisateur dans les fenêtres et l'ajouter au groupe IUSER, et ajouter des droits d'accès SPECIFIQUE au dossier partagé pour cet utilisateur), VOUS DEVEZ changement dans IIS les paramètres d'authentification: IIS-> site qui ont besoin> paramètres acces Authentification -> sélectionnez identité du pool aplication anonyme authentification-> Edition-> (au lieu de IUSER).

Créé 23/09/2014 à 22:06
source utilisateur

voix
0

Vous pouvez essayer $ [computername] \ IUSR> vous voulez utiliser la recherche avancée pour regarder celui-ci dans les autorisations de fenêtres.

Ou ... vous pouvez configurer votre dossier partagé en tant que lecteur sur IIS local et de l'accès de cette façon. Donc, [serverb] \ partage devient mappé à une lettre sur le serveur A et IIS accède ainsi.

Créé 01/04/2013 à 23:19
source utilisateur

voix
0

cela a fonctionné pour moi, merci. Accédez au dossier partagé -> clic droit -> propriétés -> Sécurité -> modifier -> ajouter (à ce jour comme d'habitude) -> choisir les types d'objet -> vérifier sur les ordinateurs -> entrez maintenant le nom de l'ordinateur où votre application fonctionne à partir , où vous avez publié votre application

Créé 01/04/2013 à 23:05
source utilisateur

voix
0

Assurez-vous que vous avez activé IIS pour servir du contenu statique. J'ai eu ce problème, aussi, et il m'a rendu fou jusqu'à ce que je cela.

Dans « Windows activer ou désactiver des fonctionnalités », allez à « Internet Information Services> World Wide Web Services> HTTP Caractéristiques communes> Article statique » (pour Windows 7, vous devrez trouver l'option similaire dans XP).

Je ne sais pas combien cela vous aidera, mais aussi voir la documentation de Microsoft .

Créé 17/08/2010 à 17:10
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more