FF3 / Windows CSS problème z-index avec lecteur YouTube

voix
43

Je suis coincé sur ce qui semble être un CSS / conflit z-index avec le lecteur YouTube. Dans Firefox 3 sous Windows XP, jetez un oeil à cette page: http://spokenword.org/program/21396 Cliquez sur le bouton Collect et notez que le pop-up <div> apparaît sous le lecteur YouTube. Sur d' autres navigateurs le <div> apparaît sur le dessus. Il a une valeur z-index de 999999. j'ai essayé de placer le z-index de l'élément <object> contenant le joueur à une valeur inférieure, mais cela ne fonctionne pas. Toute idée comment obtenir le pop-up à apparaître sur le lecteur?

Créé 28/11/2008 à 17:45
source utilisateur
Dans d'autres langues...                            


5 réponses

voix
100

Essayez d'ajouter le wmodeparamètre à être opaquecomme ceci:

(Notez qu'il est inclus dans les deux une <param>étiquette et un wmodeattribut sur l' <embed>étiquette.)

<object width='425' height='344'> 
    <param name='movie' value='http://www.youtube.com/v/Wj_JNwNbETA&hl=en&fs=1'> 
    <param name='type' value='application/x-shockwave-flash'> 
    <param name='allowfullscreen' value='true'> 
    <param name='allowscriptaccess' value='always'> 
    <param name="wmode" value="opaque" />
    <embed width='425' height='344'
            src='http://www.youtube.com/v/Wj_JNwNbETA&hl=en&fs=1'
            type='application/x-shockwave-flash'
            allowfullscreen='true'
            allowscriptaccess='always'
            wmode="opaque"
    ></embed> 
    </object> 
Créé 28/11/2008 à 17:57
source utilisateur

voix
3

Nous utilisons jQuery plugin Flash pour convertir les liens YouTube pour les films Flash. Dans ce cas, wmode est passé comme une option afin d'obtenir la vidéo YouTube à apparaître sous le jQuery Dialog nous ouvrons:

$('a[href^="http://www.youtube.com"]').flash(
    { width: nnn, height: nnn, wmode: 'opaque' }
);
Créé 29/07/2009 à 19:36
source utilisateur

voix
8

J'ai trouvé une pure fonction JS qui le fixent dans tous les navigateurs!

Voilà:

function fix_flash() {
    // loop through every embed tag on the site
    var embeds = document.getElementsByTagName('embed');
    for (i = 0; i < embeds.length; i++) {
        embed = embeds[i];
        var new_embed;
        // everything but Firefox & Konqueror
        if (embed.outerHTML) {
            var html = embed.outerHTML;
            // replace an existing wmode parameter
            if (html.match(/wmode\s*=\s*('|")[a-zA-Z]+('|")/i))
                new_embed = html.replace(/wmode\s*=\s*('|")window('|")/i, "wmode='transparent'");
            // add a new wmode parameter
            else
                new_embed = html.replace(/<embed\s/i, "<embed wmode='transparent' ");
            // replace the old embed object with the fixed version
            embed.insertAdjacentHTML('beforeBegin', new_embed);
            embed.parentNode.removeChild(embed);
        } else {
            // cloneNode is buggy in some versions of Safari & Opera, but works fine in FF
            new_embed = embed.cloneNode(true);
            if (!new_embed.getAttribute('wmode') || new_embed.getAttribute('wmode').toLowerCase() == 'window')
                new_embed.setAttribute('wmode', 'transparent');
            embed.parentNode.replaceChild(new_embed, embed);
        }
    }
    // loop through every object tag on the site
    var objects = document.getElementsByTagName('object');
    for (i = 0; i < objects.length; i++) {
        object = objects[i];
        var new_object;
        // object is an IE specific tag so we can use outerHTML here
        if (object.outerHTML) {
            var html = object.outerHTML;
            // replace an existing wmode parameter
            if (html.match(/<param\s+name\s*=\s*('|")wmode('|")\s+value\s*=\s*('|")[a-zA-Z]+('|")\s*\/?\>/i))
                new_object = html.replace(/<param\s+name\s*=\s*('|")wmode('|")\s+value\s*=\s*('|")window('|")\s*\/?\>/i, "<param name='wmode' value='transparent' />");
            // add a new wmode parameter
            else
                new_object = html.replace(/<\/object\>/i, "<param name='wmode' value='transparent' />\n</object>");
            // loop through each of the param tags
            var children = object.childNodes;
            for (j = 0; j < children.length; j++) {
                try {
                    if (children[j] != null) {
                        var theName = children[j].getAttribute('name');
                        if (theName != null && theName.match(/flashvars/i)) {
                            new_object = new_object.replace(/<param\s+name\s*=\s*('|")flashvars('|")\s+value\s*=\s*('|")[^'"]*('|")\s*\/?\>/i, "<param name='flashvars' value='" + children[j].getAttribute('value') + "' />");
                        }
                    }
                }
                catch (err) {
                }
            }
            // replace the old embed object with the fixed versiony
            object.insertAdjacentHTML('beforeBegin', new_object);
            object.parentNode.removeChild(object);
        }
    }
}

Maintenant, vous pouvez simplement exécuter lorsque la page se charge avec jQuery:

 $(document).ready(function () {
            fix_flash();    
 });
Créé 26/11/2010 à 01:48
source utilisateur

voix
15

bien que la recommandation CMS est valide, il y a une mise à jour importante. Si vous souhaitez utiliser « iframe » au lieu de « Embed », ajoutez simplement ?wmode=transparentvotre lien vidéo et qui fait la magie. Je trouve cela plus simple et propre.

Mise à jour , février 2014

Il a été un certain temps et cela peut être obsolète.

Quelqu'un a rapporté que maintenant &wmode=transparenttravaille à la place.

Créé 27/07/2011 à 21:07
source utilisateur

voix
1

J'ai remarqué que wmode = « opaque » affecte terriblement sur l' utilisation du CPU. Chrome faire sur mon ordinateur portable 50% l' utilisation du processeur (sans opaque ~ 8%).
Soyez donc prudent avec cette option.

Créé 09/01/2012 à 20:06
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more