Visual Studio « Impossible de démarrer le débogage sur le serveur Web. Le serveur Web n'a pas répondu en temps opportun. »

voix
46

Je reçois l'erreur suivante assez régulièrement lors de la compilation dans Visual Studio et l'exécution de mon application web:

« Impossible de démarrer le débogage sur le serveur Web. Le serveur Web n'a pas répondu en temps opportun. Cela peut être parce qu'un autre débogueur est déjà connecté au serveur Web. »

Normalement, c'est après avoir déboguer l'application une fois déjà. A partir de la ligne de commande je lance « iisreset / restart » et il résout le problème.

Comment puis-je empêcher que cela se produise en premier lieu?

Créé 05/08/2008 à 17:18
source utilisateur
Dans d'autres langues...                            


30 réponses

voix
18

Je trouve que cela se produit si je suis le débogage avec Firefox comme navigateur. Lorsque je quitte Firefox le VS2005 / 8 session de débogage ne se termine pas. Je ne l'ai pas trouvé une solution pour cela (encore).

Si c'est ce qui se passe avec vous, alors une solution plus rapide que la course iisreset est de frapper Shift-F5 lorsque dans Visual Studio et cela mettra fin à la session de débogage en cours. Vous pouvez ensuite appuyez sur F5 et cela va démarrer une nouvelle session de débogage.

Créé 30/09/2008 à 07:04
source utilisateur

voix
17

La solution qui a fonctionné pour moi:

  1. Ouvrez Invite de commandes (Exécuter en tant qu'administrateur)

  2. Écrire iisreset /restart

  3. Maintenant, retournez à votre VS et le débogage. Il déboguer votre solution.

Il a travaillé pour Visual Studio 2013 et 2015 aussi dans mon cas.

Créé 15/01/2015 à 21:57
source utilisateur

voix
4

Après avoir essayé toutes les solutions proposées ici et dans d'autres endroits (au moins 10 approches différentes), la seule option qui a fonctionné pour moi était:

  • supprimer le site web et pool d'applications sur IIS
  • recréer site et pool d'applications sur IIS (dans mon cas, tout exactement la même configuration que précédemment)

PS: J'utilise VS 2013 et IIS 7.5 (Win7).

J'espère que cela sauve quelqu'un d'autre quelques heures.

Créé 24/02/2014 à 06:00
source utilisateur

voix
3

J'ai eu ce problème une ou deux fois. Une fois il a été résolu en prenant les conseils de Guy:

Si c'est ce qui se passe avec vous, alors une solution plus rapide que la course iisreset est de frapper Shift-F5 lorsque dans Visual Studio et cela mettra fin à la session de débogage en cours. Vous pouvez ensuite appuyez sur F5 et cela va démarrer une nouvelle session de débogage.

À une autre occasion, je devais: mettre fin à tous mes processus de travail dans les fenêtres iis gestionnaire de tâches (w3wp.exe *). Vous devriez être en mesure de frapper f5 en studio visuel pour le débogage.

Créé 26/03/2015 à 13:45
source utilisateur

voix
3

solution: aller à la tâche gestionnaire et le processus de fin aspnet_wp.exe avant l'application en cours d'exécution

Créé 28/01/2011 à 13:21
source utilisateur

voix
3

Nous utilisons une autre façon de débogage, nous ne jamais utiliser F5 plus.

Nous utilisons une macro peu comme: http://blogs.conchango.com/howardvanrooijen/archive/2007/06/24/Attach-to-Web-Server-Macro-for-Visual-Studio.aspx (qui nous liés à F6).

De cette façon, vous attachez simplement le débogueur à IIS. Il est (selon la taille du projet) beaucoup plus rapide pour vous apporter des modifications, compiler un seul projet que vous avez modifié et attacher le débogueur à nouveau.

Créé 20/08/2008 à 15:06
source utilisateur

voix
2

Pour moi, j'avais deux ouvert studio visuel. Le débogueur était déjà attaché à un autre studio visuel :). Je me suis arrêté sur le premier et a pu joindre le deuxième studio visuel.

Créé 13/12/2013 à 15:58
source utilisateur

voix
2

On dirait que vous frappez probablement F5 dans Visual Studio lorsque vous recevez cette erreur?

Il y a quelques choses que vous pouvez essayer. Le plus simple est de frapper le arrêt bouton avant de frapper la touche F5. En option, lorsque vous avez terminé le débogage et commencer à faire des changements que vous pouvez aller au débogage le menu et choisissez Arrêter le débogage ou Terminate Tous .

Créé 05/08/2008 à 17:35
source utilisateur

voix
1

Lors du débogage 2 application web (MVC 1 et 2 est MVC WebAPI) qui sont à la fois hébergé dans IIS local. Assurez-vous que chaque application utilise un pool d'applications différentes. J'ai rencontré le même problème et, dès que je change le pool d'application de l'autre, cela a fonctionné!

Créé 13/10/2016 à 13:00
source utilisateur

voix
1

Appuyez sur Maj + F5 lorsque dans Visual Studio et cela mettra fin à la session de débogage en cours. Vous pouvez ensuite appuyez sur F5 et cela va démarrer une nouvelle session de débogage.

ou

fermez votre application, ouvrez réinitialiser votre iis application et l'exécuter

Créé 07/10/2013 à 11:05
source utilisateur

voix
1

J'ai vu ce message première fois dans ma vie et je suis très confus au sujet de ce qui se passe comme il est assez évident que faire.

Je courus iisreset et il a fallu seulement 1 sec pour terminer l'exécution, et boum, je suis de retour dans le jeu.

PS J'utilise le chrome

Créé 25/08/2012 à 06:03
source utilisateur

voix
1

Si vous avez beaucoup de points de rupture cela va ralentir le processus de débogage vers le bas, donc supprimer des points de rupture et non nécessaires fermer la fenêtre Autos cela va résoudre votre problème

Créé 13/05/2009 à 08:37
source utilisateur

voix
0

Cela a fonctionné pour moi par @mtkachenko Visual Studio 2012: Impossible de joindre le processus. Un débogueur est déjà attaché «J'ai installé v2.0 outil de débogage de diagnostic et par conséquent je Debug Service de diagnostic qui démarre automatiquement et attaché à l' un des processus w3wp. Après l'arrêt et la désactivation de ce service tout fonctionne très bien. Donc , si vous obtenir de tels processus de contrôle d'erreur dans le gestionnaire de tâches qui peuvent capturer votre processus w3wp »

Créé 05/04/2017 à 19:02
source utilisateur

voix
0

Ouvrir

  • Options et paramètres Sous le débogage
  • Symboles et incontrôlées Serveurs Microsoft Symbole
  • construire solution
  • iisreset
  • solution F5 (Assurez-vous que les serveurs Microsoft Symbole unChecked nouveau)
Créé 05/09/2016 à 11:41
source utilisateur

voix
0

Je sais que c'est une vieille question, mais j'ai rencontré la même situation récemment et essayer toutes les solutions à ce poste, et pas de chance. Enfin, j'ai trouvé la solution qui fonctionne pour moi:

  1. Fermer Visual Studio
  2. Trouver Windows activer ou désactiver des fonctionnalités dans le Panneau de configuration
  3. Désactivez l' option Internet Information Services dans la boîte de dialogue pop - up
  4. Redémarrez votre ordinateur
  5. Vérifiez les services Internet dans la même boîte de dialogue, et assurez - vous Internet Information Service -> World Wide Web Services -> Fonctionnalités de développement d'applications -> ASP.NET a également été vérifiés
  6. Ouvrez Visual Studio, et maintenant votre application devrait être en mesure de fonctionner en mode débogage
Créé 31/08/2016 à 17:30
source utilisateur

voix
0

Je devais recréer le site / application / répertoire virtuel pour le faire fonctionner après avoir installé vs2015 Update3. Espérons que cela aide quelqu'un. ;)

Créé 15/07/2016 à 09:26
source utilisateur

voix
0

Cela peut aussi être causé si votre site utilise une connexion de base de données, mais le serveur de base de données est indisponible.

J'ai passé quelque temps à essayer de résoudre ce problème de la manière habituelle, mais même après le redémarrage de mon poste de travail, la question est restée. Finalement, j'ai trouvé que le service SQL Server (MSSQLSERVER) ne fonctionnait pas.

Il aurait dû être en cours d'exécution, comme il est défini sur Automatique, mais il a été arrêté, même après le redémarrage. Tous les événements MSSqlServer dans le journal des événements semblaient normaux, donc on ne sait pas pourquoi il ne fonctionnait pas, mais j'ai maintenant mis à automatique (démarrage retardé) dans l'espoir que cela réduira les conflits de ressources lors du démarrage.

Une fois que j'ai commencé MSSQLSERVER, le message "Unable to start debugging on the web server. The web server did not respond in a timely manner"ne paraissait plus et le service normal a repris.

Créé 16/12/2015 à 11:28
source utilisateur

voix
0

Eu le même problème, même après un redémarrage. Fondamentalement fait cela:

  1. Redémarrez IIS
  2. Clean Solution
  3. Régénérer la solution

Ensuite, il a commencé à travailler à nouveau.

Créé 28/08/2015 à 13:58
source utilisateur

voix
0

Très basique - mais vérifiez que si vous essayez d'exécuter le site Web de IIS en cliquant sur « Parcourir », le site fonctionne réellement.

Créé 01/04/2015 à 15:13
source utilisateur

voix
0

Avec moi, il est arrivé quand IE a été mis à jour vers une nouvelle version, est allé à des mises à jour installées, supprimé une nouvelle version de IE, après l'ordinateur redémarré, il est retourné à l'ancienne version et problème avec le débogage a été résolu

Créé 18/03/2013 à 02:01
source utilisateur

voix
0

Cela me arrive un peu express VS 2010 - En général, parce que le débogueur a cessé de répondre. Droit des fenêtres sur Barre des tâches, sélectionnez « Démarrer le Gestionnaire des tâches ». Plus que probablement le débogueur ASP.NET montrera un statut « ne répond pas ». Sélectionnez et mettre fin à tout simplement le processus.

Terminé!

Créé 10/01/2013 à 18:24
source utilisateur

voix
0

Je suis tombé sur ce problème en essayant de débogage (2) solutions distinctes dans VS.NET et les deux utilisent le serveur Web IIS pour lancer l'application. La 1ère application démarre, mais toutes les applications ultérieures commencé qui fonctionnent également via IIS affichera alors cette erreur. Il semble qu'il ne peut déboguer une application via VS.NET hébergé dans IIS à la fois.

La solution: projet d'exécution de 1 VS.NET (placer des points d' arrêt nécessaires) et démarrer la deuxième application directement à partir de IIS (non VS.NET). Vos points d' arrêt dans App 1 ( en cours d' exécution dans VS.NET) seront touchés lors de l' accès App 2 ( à partir de IIS couru directement).

Créé 04/10/2012 à 15:59
source utilisateur

voix
0

Si toutes les réponses ne fonctionne pas pour vous, tous les composants processus de bout en iis liés gestionnaire de tâches. C'est ce qui a fonctionné pour moi.

Créé 09/09/2011 à 12:30
source utilisateur

voix
0

Cette réponse ne sera appliquée si vous exécutez votre solution via IIS. Vous saurez si cela vous concerne si vous ouvrez votre site / projet en procédant comme suit: depuis Visual Studio -> Le site web Open -> IIS local -> Sélectionnez votre projet

Cette erreur Kicked mes fesses pendant 4 heures, mais finalement j'ai trouvé une réponse. J'ai d'abord essayé le iisreset / restart. Cela semblait aider un peu, mais toujours reçu la même erreur.

Ce qui a fonctionné pour moi allais (la machine xp) pour ajouter / supprimer des programmes -> Ajout / Suppression de composants Windows -> Cliquez sur IIS -> Cliquez sur « Détails ». Assurez-vous d'avoir Front Page extensions installées si vous effectuez le débogage via IIS.

Créé 17/06/2010 à 21:55
source utilisateur

voix
0

La question est normalement là quand une autre instance de iexplore est encore en cours d'exécution. Je l'habitude d'avoir la question quand mon IE se bloque mais je vois encore dans le Gestionnaire des tâches. Une fois que vous « Terminer le processus » tout est de retour à la normale :)

Créé 07/08/2009 à 12:05
source utilisateur

voix
0

On dirait que quelque chose est en train de manger les ressources de votre serveur Web. Peut-être que vous avez des ressources (gestionnaires de fichiers, serveurs mandataires WCF) qui sont en cours d'ouverture et non fermés? J'ai eu cela me arrive surtout quand je ne ferme pas les connexions proxy WCF client.

Le problème est pas nécessairement que vous avez un débogueur attaché, mais seulement que le serveur Web ne répond pas en temps opportun. Notez que le message dit : « Cela peut être parce qu'un autre débogueur est attaché ».

Créé 05/08/2008 à 17:35
source utilisateur

voix
-1

dans votre type cmd iisreset et appuyez sur Entrée après que votre iis est remis à zéro et votre application fonctionne parfaitement

Créé 06/02/2016 à 07:09
source utilisateur

voix
-1

Essayez d'effectuer l'une des étapes suivantes pour résoudre votre problème:

  • Redémarrez votre serveur IIS
  • Nettoyer la solution de votre projet puis construire à nouveau

Si les étapes ci-dessus ne permettent pas, vous pouvez enfin essayer de redémarrer votre machine

Créé 09/07/2014 à 08:22
source utilisateur

voix
-1

Je viens de résoudre ce problème sur ma machine. Mon problème est que je mis à jour IE 9 Pour IE 10 et je suis arrivé cette erreur. Solution: Supprimer IE 10 et IE 9. déclassement à voir la section "Programmes et fonctionnalités" -> "Voir les mises à jour récentes" -> --- trouver IE 10> Il va falloir désinstaller -> reboot ---> soit 9 est de retour ---> debug ---> OK fonctionne.

Créé 25/03/2013 à 15:39
source utilisateur

voix
-2

Dans mon cas, il obtient résoudre la suppression de tous les points d'arrêt. On dirait que j'avais beaucoup de points d'arrêt (conditionnel et non conditionnel) et causais manque de ressources.

Créé 11/06/2019 à 13:09
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more