erreur de charge svnadmin

voix
4

Je reçois une erreur lors d'une tentative de restaurer un dépôt svn prélevé sur une autre machine. L'erreur est

svnadmin: flux de vidage contient un en-tête mal formé (sans « : ») à

La décharge a été créé sur un serveur Subversion 1.5 et je suis chargement vers un nouveau serveur subversion 1.6. Je suis en mesure de charger plusieurs autres référentiels avec succès sur le nouveau serveur. Le nouveau serveur est VisualSVN Server.

Créé 26/08/2009 à 22:44
source utilisateur
Dans d'autres langues...                            


5 réponses

voix
2

pour autant que je sais (je ne vois pas la décharge ..), cela se produit par la tuyauterie stdout et stderr dans le dumpfile.

Donc, vous devriez jeter à nouveau et seulement prendre stdout dans votre fichier de vidage.

Avez-vous vu la sortie alors que le dumping du référentiel ( "* révision 10 Dumped", "* Révision 11 Dumped" ..etc)?

Créé 27/08/2009 à 10:00
source utilisateur

voix
4

Essayez de nettoyer votre dump premier

grep --binary-files=text -v '^* Dumped revision' ./repository.dump > ./repository.clear-dump

essayez de charger la nouvelle décharge propre

svnadmin load /new/path/to/your/repository < ./repository.clear-dump
Créé 13/10/2010 à 03:41
source utilisateur

voix
0

J'ai eu le même problème.

Je voulais importer un fichier de vidage créé sur une boîte Linux. Le fichier a été « goudron » et gzip.

Mon dossier était un « tar.gz »

Je Winzip pour décompressé et je ne pouvais pas le télécharger en utilisant Cygwin.

Ensuite , je commande Cygwin tar -xvzfpour décompresser et j'ai pu le charger dans mon nouveau référentiel.

Créé 11/10/2011 à 21:53
source utilisateur

voix
0

Je voulais ajouter. J'ai eu le même problème que Luc M. Ma svnadmin charge REPO_PATH <commande file.svn juste ne fonctionnerait pas, l'erreur était cryptique, je ne pouvais pas travailler dehors. Donc, j'ai essayé d'utiliser tar.exe de mon Cygwin installer à nouveau sur le fichier tar que j'avais et PRESTO cela a fonctionné. J'avais aussi un fichier tar qui avait été compressé, mais je WinZip pour extraire le RAT et je pense que corrompue.

Créé 23/08/2012 à 01:10
source utilisateur

voix
0

J'ai eu le même message récemment, et à la fin, il est arrivé que j'avais transféré SVN décharges par FTP sans demander explicitement pour les transferts binaires, de sorte que les décharges ont été transférées au format ASCII. Étant donné que le serveur FTP est une machine Windows, les décharges ont été corrompues avec la ligne de Windows se termine. Par conséquent, ma recommandation est la suivante: vérifier la fin de votre ligne. Espérons que cela aide au moins un peu.

Créé 25/06/2014 à 08:29
source utilisateur

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more